quick-lint-js

Find bugs in JavaScript programs.

Install for Vim with winget

Install prerequisites

Install and configure one of the following Vim plugins:

Install quick-lint-js

quick-lint-js has a winget package, making it easy to install the CLI and LSP server on Windows.

In order to install quick-lint-js' winget package, you must first install winget. winget is included in Windows 11 and can be installed on Windows 10.

Open a command prompt or PowerShell window. Run the following command to install quick-lint-js:

winget install quick-lint-js

Install Vim plugin

Install this plugin with your favorite Vim packaging system:

Install as a Vim package

This option requires Vim 8.0 or newer.

  1. Download the quick-lint-js Vim plugin.
  2. Add packloadall to your %USERPROFILE%\_vimrc file (or %USERPROFILE%\vimfiles\vimrc) if not already present.
  3. Create the directory %USERPROFILE%\vimfiles\pack\external\start\.
  4. Copy the extracted quick-lint-js.vim directory into the %USERPROFILE%\vimfiles\pack\external\start\ directory.
  5. Restart Vim.

Install with Pathogen

This option requires Pathogen.

  1. Download the quick-lint-js Vim plugin.
  2. Copy the extracted quick-lint-js.vim directory into the %USERPROFILE%\vimfiles\bundle\ directory.
  3. Restart Vim.

Install with Vim-Plug

This option requires Vim-Plug.

  1. Add the following line to your vimrc file between call plug#begin(...) and call plug#end():
    Plug 'quick-lint/quick-lint-js', {'rtp': 'plugin/vim/quick-lint-js.vim', 'tag': '2.9.0'}
  2. Restart Vim.
  3. In Vim, run :PlugInstall.

Install with Vundle

This option requires Vundle.

Using Vundle is not recommended. Vundle doesn't support version pinning. We recommend using a different Vim plugin manager.

  1. Add the following line to your vimrc file between call vundle#begin(...) and call vundle#end():
    Plugin 'quick-lint/quick-lint-js', {'rtp': 'plugin/vim/quick-lint-js.vim'}
  2. Restart Vim.
  3. In Vim, run :PluginInstall.

Configure

Configure the Vim plugin by opening Vim and running :help quick-lint-js, or read the Vim plugin docs online.