quick-lint-js

quick-lint-js finds bugs in JavaScript programs.

Install for Vim on GNU/Linux

Install prerequisites

Install and configure one of the following Vim plugins:

Install quick-lint-js

  1. Download the latest release of quick-lint-js for your platform:

  2. Extract the downloaded archive.

  3. Copy the extracted quick-lint-js/bin/quick-lint-js file into a directory in your PATH.

    For example, copy it into the /usr/local/bin directory.

  4. Open a terminal window. Type quick-lint-js --version and press enter to verify the installation succeeded.

Install Vim plugin

Install this plugin with your favorite Vim packaging system:

Install as a Vim package

This option requires Vim 8.0 or newer.

  1. Download the quick-lint-js Vim plugin.
  2. Add packloadall to your ~/.vimrc file if not already present.
  3. Create the directory ~/.vim/pack/external/start/.
  4. Copy the extracted quick-lint-js.vim directory into the ~/.vim/pack/external/start/ directory.
  5. Restart Vim.

Install with Pathogen

This option requires Pathogen.

  1. Download the quick-lint-js Vim plugin.
  2. Copy the extracted quick-lint-js.vim directory into the ~/.vim/bundle/ directory.
  3. Restart Vim.

Install with Vim-Plug

This option requires Vim-Plug.

  1. Add the following line to your vimrc file between call plug#begin(...) and call plug#end():
    Plug 'quick-lint/quick-lint-js', {'rtp': 'plugin/vim/quick-lint-js.vim', 'tag': '0.5.0'}
  2. Restart Vim.
  3. In Vim, run :PlugInstall.

Install with Vundle

This option requires Vundle.

Using Vundle is not recommended. Vundle doesn't support version pinning. We recommend using a different Vim plugin manager.

  1. Add the following line to your vimrc file between call vundle#begin(...) and call vundle#end():
    Plugin 'quick-lint/quick-lint-js', {'rtp': 'plugin/vim/quick-lint-js.vim'}
  2. Restart Vim.
  3. In Vim, run :PluginInstall.

Configure

Configure the Vim plugin by opening Vim and running :help quick-lint-js, or read the Vim plugin docs online.