quick-lint-js

Find bugs in JavaScript programs.

Install for Sublime Text on macOS

Install prerequisites

Install the LSP Sublime Text package:

  1. Open Sublime Text.
  2. Open the Command Palette (press Control-Shift-P) and type "Install Package Control".
  3. Open the Command Palette and type "Package Control: Install Package", then type "LSP".

Install quick-lint-js

  1. Download the latest release of quick-lint-js for your platform:

  2. Extract the downloaded archive.

  3. Copy the extracted quick-lint-js/bin/quick-lint-js file into a directory in your PATH.

    For example, copy it into the /usr/local/bin directory.

  4. Open a terminal window. Type quick-lint-js --version and press enter to verify the installation succeeded.

Configure Sublime Text

After installing quick-lint-js, you need to register quick-lint-js in Sublime Text's LSP package:

  1. Open Sublime Text.
  2. Open the Command Palette (press Control-Shift-P) and type "Preferences: LSP Settings".
  3. In the LSP.sublime-settings file which opens, add the following code. If "clients" already exists, add "quick-lint-js" inside the existing { }:
    {
        "clients": {
            "quick-lint-js": {
                "command": ["quick-lint-js", "--lsp-server"],
                "enabled": true,
                "languageId": "javascript",
                "syntaxes": ["Packages/JavaScript/JavaScript.sublime-syntax"]
            }
        }
    }
    
Sublime Text with LSP.sublime-settings open, showing closure-lsp and quick-lint-js settings
Example LSP settings for Sublime Text